Ansichten:

Problem:

Schlösser lassen sich generell mit Data Transfer App einsammeln, aber einige wenige Schlösser können nicht in die LMS übertragen werden. Es kmommt eine Fehlermeldung und der Prozess bricht ab.

 

Ursache 1:

Mathematisches Problem mit der Schloss ID

Lösung 1:

Update der LMS auf 1.4.1 oder höher. Damit ist das Problem behoben.

 

Ursache 2:

Schloss wurde bereits angelernt, ist aber in der Datenbank nicht mehr verfügbar (z.B.durch Restore eines älterne Backups, Schloss mit der Löschen Funktion gelöscht, Datenverlust in der Datenbank)

Lösung 2:

In der LMS gibt es eine Database-Recovery-Funktion. Diese Funktion ist standartmäßig immer deaktiviert und solle nur im äußersten Notfall verwendet werden. Vor Verwendung dieser Funktion solle unbedingt ein Backup erstellt werden. Nach anlernen der Schlösser sollte die Funktion wieder deaktiviert werden.

1. Aktivieren der Recovery Funktion:

   Beenden Sie die LMS

   Öffnen sie mit dem Windows Explorer die Datei 

   C:\Users\"eigener Benutzername"\AppData\Roaming\LEHMANN-Locks\LEHMANN Management Software\SettingsLMS.xml

   mit dem Windows Editor. Ändern Sie dann die Zeile:    <AllowDbRestore>false</AllowDbRestore> in   <AllowDbRestore>true</AllowDbRestore> und speichern Sie die Datei ab.

   Starten Sie die LMS.

2. Lernen Sie das Schoss in der LMS an, es sollte nun keine Fehlermeldung mehr kommen.

3. Beenden Sie die LMS und öffnen Sie die Datei:

  C:\Users\"eigener Benutzername"\AppData\Roaming\LEHMANN-Locks\LEHMANN Management Software\SettingsLMS.xml

erneut mit dem Windows editor und ändern SIe die Zeile <AllowDbRestore>true</AllowDbRestore> zurück in   <AllowDbRestore>false</AllowDbRestore> und speichern diese danach ab.